[35818] in Kerberos

home help back first fref pref prev next nref lref last post

Re: On IETF JGSS interface

daemon@ATHENA.MIT.EDU (Nico Williams)
Tue Mar 4 15:50:18 2014

MIME-Version: 1.0
In-Reply-To: <CAEvOXU7qKa+YN4V=LfeBCFMwLX8Q1D8OrQqkitZ5n0iy=OP40w@mail.gmail.com>
Date: Tue, 4 Mar 2014 14:50:00 -0600
Message-ID: <CAK3OfOh3ZqqycTkM+jk6P6WRVz=a2-hf7bJyUvYEh2PoykcA4A@mail.gmail.com>
From: Nico Williams <nico@cryptonector.com>
To: Arpit Srivastava <arpit.orb@gmail.com>
Cc: kerberos <kerberos@mit.edu>
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Errors-To: kerberos-bounces@mit.edu

On Tue, Mar 4, 2014 at 8:59 AM, Arpit Srivastava <arpit.orb@gmail.com> wrote:
> What is the license of IETF JGSS interface (
> http://www.ietf.org/rfc/rfc2853.txt), given that I would be implementing
> the interface using MIT Kerberos APIs, defined in the Java package
> "org.ietf.jgss" ?

RFC5653 obsoletes RFC2853 and uses a three-clause revised BSD license
for the code embedded in it.

Assuming you'd be using the GSS-API C bindings to implement the Java
bindings, I don't see how the MIT Kerberos license comes into play,
since you could link with any GSS-API C bindings implementation, of
which there are at least four to my knowledge.  The C bindings
licensing would be specified in RFC2744, but it doesn't really have a
license for the C header bits.

Nico
--
________________________________________________
Kerberos mailing list           Kerberos@mit.edu
https://mailman.mit.edu/mailman/listinfo/kerberos

home help back first fref pref prev next nref lref last post